Dedicated Server: How I set mine up

Want to learn or teach others some of the finer details of Life is Feudal? This section is for the game guides, tutorials and FAQ's.

Hambeast
Alpha Tester
 
Posts: 28
Joined: 16 Sep 2014, 01:12

Dedicated Server: How I set mine up

Post by Hambeast » 19 Sep 2014, 20:56

OK, after a furious bug report and then realizing I was being an idiot, I finally got my server up and running...

Read the damn readme file btw, this is how I did it and if you are not fluent with mysql dba or if you are a new users your mileage may vary.

Here's how I did it:

Step 1. Install LIF dedicated server (under steam tools)
Step 2. Have MySQL DB installed already
Step 3. Create user for DB and modify config
Step 4. Create DB named LiF_1 (1 is the instance) (utf8_unicode_ci)
Step 5. Run sql script against LiF_1
Step 6. Config the XML file to your liking
Step 7. Set up service to run dedicated server ( I used firedaemon)
Step 8. Verify that you have a firewall exception (should be created for you)


If you choose to forego the readme and do this yourself with an existing DB engine, you MUST make sure the charset is utf8_unicode_ci. If you don't you're going to have a bad time...

User avatar
Arrakis
 
Posts: 5421
Joined: 25 Oct 2013, 14:11
Location: Sparksvaard, the middle world; the world of people.

Re: Dedicated Server: How I set mine up

Post by Arrakis » 19 Sep 2014, 21:18

Moved to tutorials, this will be helpful for many players.



Hambeast
Alpha Tester
 
Posts: 28
Joined: 16 Sep 2014, 01:12

Re: Dedicated Server: How I set mine up

Post by Hambeast » 19 Sep 2014, 21:35

Thanks Arrakis,

I'm not at home so I don't have much ability to take screenshots but I'll flesh the guide out a bit more when I get home.


valirius
Alpha Tester
 
Posts: 80
Joined: 28 Nov 2011, 11:20
Location: Time-paradox.net

Re: Dedicated Server: How I set mine up

Post by valirius » 19 Sep 2014, 21:47

But this gives an error. Got any ideas how to fix?

Spoiler


which version of mysql turned to run?
ImageYou are entering    Time ParadoxImage

User avatar
Enigma
 
Posts: 5
Joined: 17 Dec 2013, 08:30

Re: Dedicated Server: How I set mine up

Post by Enigma » 20 Sep 2014, 04:34

Any chance we can get a video tutorial placed up? I'm a complete nub when it comes to MySQL, and have no idea what the readme file is talking about? I'll have a read over it again a few times, but ya...


Peasant
 
Posts: 12
Joined: 16 May 2014, 04:13

Re: Dedicated Server: How I set mine up

Post by Peasant » 20 Sep 2014, 04:50

not working for us. getting CR_INTERNAL_DB ERROR when trying to join the server.

It seems like the new.sql file is broken because it comes up with errors on import.


valirius
Alpha Tester
 
Posts: 80
Joined: 28 Nov 2011, 11:20
Location: Time-paradox.net

Re: Dedicated Server: How I set mine up

Post by valirius » 20 Sep 2014, 08:45

Peasant wrote:not working for us. getting CR_INTERNAL_DB ERROR when trying to join the server.

It seems like the new.sql file is broken because it comes up with errors on import.

Nope) just use MariaDB 5.5 (exactly ver 5.5). and all will be right
ImageYou are entering    Time ParadoxImage


Corelegend
 
Posts: 19
Joined: 20 Sep 2014, 16:52

Re: Dedicated Server: How I set mine up

Post by Corelegend » 20 Sep 2014, 16:58

I have same problems here. Iam using mariaDB 5.5.

Failure message after loading new.sql:
/* SQL Fehler (1064): You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 3 */

Any ideas?


Peasant
 
Posts: 12
Joined: 16 May 2014, 04:13

Re: Dedicated Server: How I set mine up

Post by Peasant » 20 Sep 2014, 22:51

mariaDB 5.5.39 is the only 5.5 option it gives me, and no same DB error while trying to connect if I import the DB as stated in this guide. 449 sql errors on import.


Corelegend
 
Posts: 19
Joined: 20 Sep 2014, 16:52

Re: Dedicated Server: How I set mine up

Post by Corelegend » 21 Sep 2014, 13:41

Solved! You have to load the .sql file in one batch.


Mosnyua
 
Posts: 1
Joined: 21 Sep 2014, 13:16

Re: Dedicated Server: How I set mine up

Post by Mosnyua » 21 Sep 2014, 18:22

Hey,
I have the same error 1064, i tryed to load the database with a batch cmd of mariaDB but same error
It looks like this (but there is 100 line of errors after this) :

Spoiler


I have vers. 5.5.39 of mariaDB.

ps: i have followed this tutorial : http://steamcommunity.com/sharedfiles/f ... =316928535


Kakusha
 
Posts: 9
Joined: 29 Sep 2014, 03:19

Re: Dedicated Server: How I set mine up

Post by Kakusha » 30 Sep 2014, 09:19

EDIT: 2014/10/01
It seems like the problem is that WINE is not supporting "WinHttpDetectAutoProxyConfigUrl".
Are there any way to avoid or bypass this?


HI, I'm currently striving to run YO: dedicated server on linux with WINE.
Yes I'm stuck but there's some question I thought can ask here.

1. Is this err log usual? This happens multiple times when starting the server.
Code: Select all
<onServerCreated> Error: cannot change namespace parent linkage of Armor from PlayerData to AI_AnimalData.

I don't see any other ERR log except tons of warnings.

I can create a character. However,when the client pushes play button, loading screen says "waiting for server" but cannot proceed any further.
The console log was stuck at below point and did not proceed, too. Processes wineserver and ddctd~~.exe didn't crash per se.
<NOSCOPE> packItemStatic: 2 | 297 | 50 | 0 1
I also found that, after waiting several minutes, it says
Code: Select all
fixme:winhttp:WinHttpDetectAutoProxyConfigUrl discovery via DHCP not supported

2. So, If the namespace errs are usual things, is it safe to say the problems are in using WINE? or in my other wrong settings or so?

Thanks in advance, any help would be appreciated!


Kakusha
 
Posts: 9
Joined: 29 Sep 2014, 03:19

Re: Dedicated Server: How I set mine up

Post by Kakusha » 02 Oct 2014, 07:53

Finally I got it working on my headless Linux(CentOS6) vps with wine!
To tell the truth, winhttp was not the problem...
I'll create a new thread and share how-tos if there are still none.


ViZartDk
 
Posts: 4
Joined: 02 Oct 2014, 14:23

Re: Dedicated Server: How I set mine up

Post by ViZartDk » 02 Oct 2014, 14:40

Hi.

Ive followed this guide but I have som problems. Im hoping someone can give me a tip on how to solve them.

MySQL: I already have a MySQL server running, so i would like to avoid using MariaDB. Ive gotten so far that i have pointed my configuration to the my.ini, ive created a scheme with the stated uft8 character set. I imported the sql script in one go, but here it starts to go wrong.

I get the data in correctly, then when i reach line 140819 and it fails with this error message:

Spoiler


The line at that place is:

Spoiler


Ive tried to change the user name in that line to the lif user ive recreated, but that doesnt help.

And it seems like it get the data in correctly, but not the stored procedures. Because when i start the server its mostly green, but when it after a while does "something" it gets a lot of error saying that it cant find the procedure.

Second problem is that my server doesnt apear on the steam server list. I wanted to try to connect, just to see if it was possible but i cant. Does you have to do something to get it to show? Ive forwarded port 28000, 26001, 26002 and 26003 (read in another guide) and ive waited an hour or so, but it doesnt apear on the steam list.

Is it possible to access a server via an ip? Or is the only way throw the steam list?

I would really really like to get this running. But i will prefer to use my MySQL server as the database.


Kakusha
 
Posts: 9
Joined: 29 Sep 2014, 03:19

Re: Dedicated Server: How I set mine up

Post by Kakusha » 02 Oct 2014, 15:36

Hi ViZartDk.
I've tried MySQL but got the same syntax error and procedures weren't created, neither. MySQL and MariaDB is not completely compatible, you know...
I think we need to use MariaDB5.5 because of that problem.

Second, you need to edit /SRVROOT/config/world_x.xml and set base port number (say, set it to 26000).
Then, you need to open ports which are up to +2 from base port.
So, if you set 26000 for base port, you need to open 26000:26002.

Hope this helps a little. :)


ViZartDk
 
Posts: 4
Joined: 02 Oct 2014, 14:23

Re: Dedicated Server: How I set mine up

Post by ViZartDk » 05 Oct 2014, 08:24

Hi Again

Now I have gotten the database problem fixed. I now have the dedicated server software running without errors with MySql database.

BUT

I still dont see my server on the server list. I have set it to port 26000 and forwarded port 26000:26002 TCP and UDP to my computer on my router.

Any ideas?? What am I doing wrong??

Edit: I have tested the port with an online port tester, and it is open, and I could see the ping from the site in the server console.


Fouc
 
Posts: 9
Joined: 07 Oct 2014, 16:43

Re: Dedicated Server: How I set mine up

Post by Fouc » 07 Oct 2014, 16:45

Hi,

I saw that you've succeeded into using mysql database.

Could you please share your corrected mysql file used or a database dump for other people like me who didn't succeeded yet?

Many thanks in advance.
fouc

User avatar
Razoreqx
 
Posts: 91
Joined: 06 Oct 2014, 13:13

Re: Dedicated Server: How I set mine up

Post by Razoreqx » 22 Oct 2014, 00:55

Can you elaborate on any special commands or switches you enabled on FireDaemon? I get a popup saying this program might need additional privileges? Any ideas? it does load the server but that dialog box does continue to come up

Any special variables, environments, option flags... etc.
Razors Edge
A Life is Feudal Persistent World
http://razors-edge.org
22 Custom MODS / Custom Graphics models Planned. Visit our Gallery.

Return to Guides and Tutorials

cron