Heraldrik Bugged?

General discussion about Life is Feudal MMO and Life is Feudal: Your Own, The main section and backbone of the forums.

TheZar
 
Posts: 108
Joined: 20 Jan 2015, 01:50

Re: Heraldrik Bugged?

Post by TheZar » 01 May 2016, 03:57

Are you in GM Mode? GM Mode can affect it from working properly, when i did mine i had to log a couple of times and reapply the symbols


Arris
 
Posts: 12
Joined: 22 Feb 2015, 23:21

Re: Heraldrik Bugged?

Post by Arris » 01 May 2016, 08:44

I wasn't in GM mode. No idea about other people in this thread.
Image


Halvdal
 
Posts: 109
Joined: 20 Jan 2016, 13:36

Re: Heraldrik Bugged?

Post by Halvdal » 01 May 2016, 12:14

No, no GM mode here. Would be nice if any Dev can say something about that. I think BasilMod is not the Problem.

Fresh Server and Client install doesn't make it work.

----------------------

Update:

Finally i got an error in my logs.

Spoiler


--------------------------------

Update:

Got it!

- Open your LiF DB with HeidiSQL
- Go to table heraldic_charges
- Change the standard coalliton to utf8_general_ci
Image
- do the same for the heraldries table

- start server and profit

:good:


Alakar
Beta Tester
 
Posts: 203
Joined: 23 Jan 2015, 07:39

Re: Heraldrik Bugged?

Post by Alakar » 01 May 2016, 13:31

Sounds like an issue with the sql server there. Maybe check the configuration of it?


MacDante
 
Posts: 95
Joined: 12 May 2015, 10:08

Re: Heraldrik Bugged?

Post by MacDante » 01 May 2016, 18:14

lol:

ERRR 2016-05-01 19:16:32.565 {} <> [98930] DB error #1305: PROCEDURE lif_9664.p_addHeraldry does not exist. Query: CALL p_addHeraldry(5,12,3, 1,1,7,'top_left','small', 0,0,0,'','');
WARN 2016-05-01 19:16:32.566 {} <> [98930] DB::mfRS(1 ms) CALL p_addHeraldry(5,12,3, 1,1,7,'top_left','small', 0,0,0,'','');
ERRR 2016-05-01 19:16:32.566 {} <> [98930] Heraldry::Info::saveToDb() - can't save heraldry to DB
ERRR 2016-05-01 19:16:32.566 {} <> [98930] CreateGuildHeraldryReqEvent::process() - can't create heraldry

check in logs. If Heraldric don'work on yours server and procedure does not exist. ENter to HEIDI and in query copy this and run:

Spoiler


if you change UTF you should back to old settings...

User avatar
Arrakis
 
Posts: 5474
Joined: 25 Oct 2013, 14:11
Location: Space

Re: Heraldrik Bugged?

Post by Arrakis » 16 May 2016, 11:49

Halvdal wrote:- Open your LiF DB with HeidiSQL
- Go to table heraldic_charges
- Change the standard coalliton to utf8_general_ci
http://abload.de/img/heraldrychargestabel3dsi4.jpg
- do the same for the heraldries table

Actually that is a bit inaccurate :crazy: What you need to do is:
- Shut down the server first
- Update DB by setting coallition to utf8_unicode_ci
- Restart the server

Note: In some cases DB collation is messed during DB exports done in Heidi and you have to change it manually.



Larainan
 
Posts: 83
Joined: 08 Sep 2015, 15:19

Re: Heraldrik Bugged?

Post by Larainan » 16 May 2016, 14:39

Halvdal, I am happy to see that the switch to utf8_general_ci worked for you. My server was installed that way from the get go and I always make sure imports are set that way as well. We still have that bug you describe on the server.

Some of our players have had success with fixing it by verifying their game files in steam on the client end but not all have been lucky.

Arrakis thanks for the comment I will try switching to Unicode first then the script above your message if that does not work.

I didn't look at the persons name that posted it before hitting reply but thanks very much for the information and the effort going through the files to find answers and making them public.

Though Heraldry is less of a concern than tanning tubs lol that keeps me pretty busy through the day, I am glad to see there are solutions and suggestions being put out there for everyone


Catherine
 
Posts: 31
Joined: 01 Mar 2016, 10:00

Re: Heraldrik Bugged?

Post by Catherine » 12 Oct 2016, 09:42

my database error since yesterday suddenly out of nothing:

ERRR 2016-10-12 10:34:28.426 {} <> [2665812] DB error #1267: Illegal mix of collations (utf8_unicode_ci,IMPLICIT) and (utf8_general_ci,IMPLICIT) for operation '='. Query: CALL p_addHeraldry(2,13,16, 1,1,1,'true_center','large', 0,0,0,'','');

WARN 2016-10-12 10:34:28.426 {} <> [2665812] DB::mfRS(0 ms) CALL p_addHeraldry(2,13,16, 1,1,1,'true_center','large', 0,0,0,'','');

ERRR 2016-10-12 10:34:28.426 {} <> [2665812] Heraldry::Info::saveToDb() - can't save heraldry to DB

ERRR 2016-10-12 10:34:28.427 {} <> [2665812] CreateGuildHeraldryReqEvent::process() - can't create heraldry

________________________________


i have checked everything but dont see whats going on.
the utf8_general_ci is exacly how it supose to be.
Anyone an idea how to fix this?


(NVMD!!! FIXED IT!!!)
I didnt seen this message:
http://abload.de/img/heraldrychargestabel3dsi4.jpg

thx anyway!


Tlocsmokes
 
Posts: 2
Joined: 13 Jun 2016, 22:36

Re: Heraldrik Bugged?

Post by Tlocsmokes » 29 Dec 2016, 11:20

I have no heraldry table? how am i supposed to fix this internal error? im so confused.


Hildolf
True Believer
 
Posts: 3
Joined: 15 Jun 2016, 11:15

Re: Heraldrik Bugged?

Post by Hildolf » 29 May 2017, 08:40

I have The same problem but in addition all tabards are in blank without modifications... Any can help me?

Return to General Discussion