Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Have some feedback for Life is Feudal? Post it here!
User avatar
XeenMcKenna
 
Posts: 119
Joined: 09 Nov 2014, 18:36

Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by XeenMcKenna » 10 Nov 2016, 04:13

Had this pinned in the Steam Tech support page for almost a year. Had a post here but it is buried. Figured I would post it since it seems to still be useful.

Fix 1
Turn off Nvidias Experience, AMDs Gaming Evolved, or any other overlay software you have running. They are causing big problems with the game.

If you have optimized the game with these clients, you will be required to reload the game. Do not optimize the game with either piece of software. If you have done this, reinstall the game after removing it completely.

You also may need to completely delete either program for this to work.

Fix 2
This is for laptops with dual graphics, mainly considering Intel onboard graphics
http://www.tomshardware.com/answers/id- ... s-amd.html

Another choice (instead of infraworks, use LiF)
https://knowledge.autodesk.com/support/ ... Works.html

Fix 3
For FPS issues
limit the drawing distance of the ACTUAL island, to do this u need to go to
Steam\SteamApps\common\Life is Feudal Your Own\scripts\client
and open cm_environment.cs
find
visibleDistance = "10000";
and set it to 200-500, depends on how u want it, i'm setting mine to 200 for more fps but i'm limiting my vision, 500 should be more than enough for good vision, also set the ingame vision bars to the same number too. u can do it from
Steam\SteamApps\common\Life is Feudal Your Own\data
prefs.cs
$pref::TS::renderingDistanceBig = "200";
$pref::TS::renderingDistanceHuge = "200";
$pref::TS::renderingDistanceSmall = "200";
also this is known but i'm still gonna write it here, in the same file prefs.cs
change this
$pref::Shadows::disable = "1";
$pref::Video::antiAliasing = "0";
$pref::Water::disableTrueReflections = "1";
$pref::windEffectRadius = "0"; <<(no idea if it does anything i just changed it)

from 1-5 fps while moving camera i went to 30-50.


Fix 5
DX11 problem
go to game list, go to properties for LiF, go to beta, enable DX9 version... if that works, either your video card does not support DX11 or you have an on board video card that is taking over. See fix 2

Fix 6
Update. For some players our game does not start AT ALL. Actually that is Steam's fault, because it does not install C++ redistr properly. You should navigate to game folder and manually launch:
...common\Life is Feudal Your Own\_CommonRedist\vcredist\2013\vcredist_x86.exe
...common\Life is Feudal Your Own\_CommonRedist\vcredist\2010\vcredist_x86.exe
...common\Life is Feudal Your Own\_CommonRedist\vcredist\2008\vcredist_x86.exe

Fix 7
Latest windows update has been a problem for a couple people... Try rolling back to previous

Fix 8
Disable all programs running, including your antivirus. If that works, disable them one at a time and see what is blocking you.

Fix 9
For Performance issues
Unpark your CPU cores, google it (Intel problem mainly)
Last edited by XeenMcKenna on 07 Dec 2016, 04:36, edited 1 time in total.
Image

User avatar
Saar
Zealous Believer
 
Posts: 311
Joined: 05 Jul 2016, 14:26
Location: Toulouse - France

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Saar » 05 Dec 2016, 10:42

Traduction française sur le site von Culm
Last edited by Saar on 06 Mar 2017, 19:07, edited 1 time in total.

User avatar
Azzerhoden
Alpha Tester
 
Posts: 1623
Joined: 08 May 2014, 17:44

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Azzerhoden » 06 Dec 2016, 04:35

Can we get this stickied? Have had several folks run into issues lately.
| - Alpha Tester and Zealous Believer
Image

Kingdom of Hyperion founding Duchy - A practical RP Community est. 1999 - Apply Today!

User avatar
Arrakis
 
Posts: 5426
Joined: 25 Oct 2013, 14:11
Location: Sparksvaard, the middle world; the world of people.

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Arrakis » 06 Dec 2016, 13:16

Azzerhoden wrote:Can we get this stickied? Have had several folks run into issues lately.
It is sticked since the day it was posted :crazy:


User avatar
Azzerhoden
Alpha Tester
 
Posts: 1623
Joined: 08 May 2014, 17:44

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Azzerhoden » 06 Dec 2016, 18:25

HAHAHAHA - you can tell I only ever look at new posts. :D
| - Alpha Tester and Zealous Believer
Image

Kingdom of Hyperion founding Duchy - A practical RP Community est. 1999 - Apply Today!

User avatar
XeenMcKenna
 
Posts: 119
Joined: 09 Nov 2014, 18:36

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by XeenMcKenna » 07 Dec 2016, 04:36

If anyone has any suggestions to update this let me know
Image


Tadan
 
Posts: 12
Joined: 04 Feb 2017, 16:46
Location: BRAZIL

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Tadan » 20 Feb 2017, 17:25

Hi i cant access the lif mmo i have this error

Image

User avatar
Trilly
Zealous Believer
 
Posts: 1
Joined: 20 Jan 2017, 18:37

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Trilly » 20 Feb 2017, 17:41

Has anyone been able to troubleshoot this issue?

Image

User avatar
Saar
Zealous Believer
 
Posts: 311
Joined: 05 Jul 2016, 14:26
Location: Toulouse - France

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Saar » 20 Feb 2017, 19:04



Derkice
True Believer
 
Posts: 4
Joined: 17 Jan 2015, 16:55

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Derkice » 20 Feb 2017, 20:14

Just updated, and got this error along with Failed to initialize game, shutting down.
Attachments
LIF error.jpg
LIF error.jpg (22.1 KiB) Viewed 6447 times


Szekszy
True Believer
 
Posts: 7
Joined: 04 Oct 2014, 22:48

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Szekszy » 20 Feb 2017, 20:21

i have the same problem...
Should i repair?


Zmit
Devoted Believer
 
Posts: 1
Joined: 09 Feb 2017, 17:23

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Zmit » 20 Feb 2017, 20:30

same here anyone know what is happening no news on home page of website


Derkice
True Believer
 
Posts: 4
Joined: 17 Jan 2015, 16:55

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Derkice » 20 Feb 2017, 21:11

Szekszy wrote:i have the same problem...
Should i repair?



I wouldn't bother, it doesn't fix the issue.

User avatar
Dyu
Zealous Believer
 
Posts: 22
Joined: 18 Jan 2016, 05:17

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Dyu » 20 Feb 2017, 21:13

Same issue.....
Initial Success or Total Failure


RecklessTactics98
True Believer
 
Posts: 1
Joined: 29 Oct 2016, 23:07

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by RecklessTactics98 » 20 Feb 2017, 22:11

I got the same error

User avatar
Arrakis
 
Posts: 5426
Joined: 25 Oct 2013, 14:11
Location: Sparksvaard, the middle world; the world of people.

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Arrakis » 20 Feb 2017, 22:32

RecklessTactics98 wrote:I got the same error

What error?


User avatar
ROG
Beta Tester
 
Posts: 76
Joined: 17 Oct 2015, 20:44

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by ROG » 20 Feb 2017, 22:40

Arrakis wrote:
RecklessTactics98 wrote:I got the same error

What error?


Ошибка восприятия действительности :D


Szekszy
True Believer
 
Posts: 7
Joined: 04 Oct 2014, 22:48

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Szekszy » 21 Feb 2017, 07:57

After running start icon and uptating launcher, nothing happens....

User avatar
Arrakis
 
Posts: 5426
Joined: 25 Oct 2013, 14:11
Location: Sparksvaard, the middle world; the world of people.

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Arrakis » 22 Feb 2017, 11:44

Szekszy wrote:After running start icon and uptating launcher, nothing happens....

Please install Update for Universal C Runtime In Windows.


User avatar
Mage
Zealous Believer
 
Posts: 32
Joined: 01 Dec 2016, 22:29
Location: São Paulo - Brazil

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Mage » 24 Feb 2017, 03:37

Hi,

My game is having black screens with certain characters. After i choose, screen goes black in 2 different computers.

Any idea? Thanks a lot.
Image

User avatar
Arrakis
 
Posts: 5426
Joined: 25 Oct 2013, 14:11
Location: Sparksvaard, the middle world; the world of people.

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Arrakis » 26 Feb 2017, 18:50

This is known issue - on our side. So far server restarts help, but we are also looking for permanent solution to this problem.



Lokir
Zealous Believer
 
Posts: 1
Joined: 23 Feb 2017, 11:46

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Lokir » 26 Feb 2017, 22:16

Arrakis wrote:This is known issue - on our side. So far server restarts help, but we are also looking for permanent solution to this problem.


thanks for looking into this. I have hours on end spent frozen out of the game with a black screen like this. If possible, plz restart 26


Moerti84
True Believer
 
Posts: 10
Joined: 12 Oct 2014, 17:59

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Moerti84 » 17 Nov 2017, 17:38

Hey, I don´t know if already mentioned.

I cannot join the game. After the intro a message appears with "wrong version" and after clicking ok it just CTD.

When I hit "repair" in the launcher then the DL is ultra low and stops at about 20 % completely.

is there a work around known?


Akwaccc
 
Posts: 5
Joined: 30 Nov 2017, 20:01

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Akwaccc » 03 Dec 2017, 11:38

Может кто-то сталкивался с подобным.
Приобрёл бронзовый пакет доступа.
Скачал лаунчер и установил игру.
Создал персонажа, но во время загрузки мира "Загрузка мира 3/9" выбивает ошибку "Сервер разорвал соединение".
Поддержка пока не отвечает на письма.


Disvet537
 
Posts: 8
Joined: 06 Dec 2017, 18:05

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Disvet537 » 14 Dec 2017, 11:10

Kinda funny how we have to fix things on our end, don'cha think?


STeelGear
 
Posts: 12
Joined: 20 Dec 2014, 08:34

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by STeelGear » 15 Dec 2017, 04:55

Launcher Issue.
When new update is coming, launcher can't provide self-update. It makes download, unpack and... aborting. After aboring, launcher starts this cycle again, and again and...
Moreover, before updates, when all was ok, launcher can't normaly close. Every time it shows error after closing.

Description in error window:

Сигнатура проблемы:
Имя события проблемы: APPCRASH
Имя приложения: launcher.exe_Life is Feudal
Версия приложения: 1.6.3.0
Отметка времени приложения: 5a2a645f
Имя модуля с ошибкой: Qt5Core.dll
Версия модуля с ошибкой: 5.8.0.0
Отметка времени модуля с ошибкой: 587fd6c7
Код исключения: c0000005
Смещение исключения: 00000000001de859
Версия ОС: 6.1.7601.2.1.0.256.1
Код языка: 1049
Дополнительные сведения 1: 14a7
Дополнительные сведения 2: 14a70bb054f4c35519d975a7a1534222
Дополнительные сведения 3: ed68
Дополнительные сведения 4: ed687834c8e489de12cb9c2dac657d06

User avatar
Arrakis
 
Posts: 5426
Joined: 25 Oct 2013, 14:11
Location: Sparksvaard, the middle world; the world of people.

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Arrakis » 15 Dec 2017, 12:01

STeelGear wrote: Версия приложения: 1.6.3.0

First of all, please update your launcher. Current version is 1.6.5.0



STeelGear
 
Posts: 12
Joined: 20 Dec 2014, 08:34

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by STeelGear » 16 Dec 2017, 08:54

Arrakis wrote:
STeelGear wrote: Версия приложения: 1.6.3.0

First of all, please update your launcher. Current version is 1.6.5.0


How I can update launcher when it CAN NOT complete self-update???
But problem was solved by reinstalling. But again, It's not complete solving, it's temporary solution


Redmantle
 
Posts: 86
Joined: 03 Jan 2018, 01:12

Re: Wont Launch?? FPS Issues?? Video Issues?? Black/Gray Screen??

Post by Redmantle » 15 Jan 2018, 01:00

Wait, so having Nvidia Geforce Experience installed or on even if you dident launch the game through it or optimise it through it create fps issues?

Return to Feedback Section