Cant launch the game

General discussion about Life is Feudal: Your Own, The main section and backbone of the forums.

Posts: 1
Joined: 10 Nov 2017, 01:40

Cant launch the game

Post by Madseaker » 10 Nov 2017, 01:57

Ok i just bought the game installed it and downloaded all files. When i tried to play the game it started with message launching life if feudal your own as it does every time i press play or dclick on destop shortcut, but the it doesnt load the game not even for second it just puts up error that sayes (cant init steam module. Exiting..)and after that nothing happens.

What i tryed that didnt work:

-Restarting steam as loging in and out and closeing down steam client and every thing that steam is not working.
-Deleting steam and installing it back.
-Restating PC.
-Varify the game ( didnt get any updateds after).
-Deleting deamon file in game folder and then varify the game.
-Repearing c++ files.
-Uninstalling and installing it back.
-Disable comodo antivirus that i have.
-Puting this game as safe in firewall.

and from all that the game still has the same error and it wont start. So i really need help if anyone has any idea left what to do?


Posts: 35
Joined: 01 Nov 2016, 12:45

Re: Cant launch the game

Post by Bjarkan » 18 Nov 2017, 21:00

my account and verified but I have not received any key for the test of the MMO I already looked at the trash of the email already looked at spaw I already looked at everything I do not have email with key pro mmo test

Posts: 2
Joined: 11 Jan 2018, 15:13

Re: Cant launch the game

Post by Rickster_79606 » 11 Jan 2018, 17:10

check your gfx card to see if it will run the game. game debate is a good site to check with.

Return to General Discussion