LiF YO Not Working!!

General discussion about Life is Feudal: Your Own, The main section and backbone of the forums.

Posts: 1
Joined: 30 May 2015, 06:32

LiF YO Not Working!!

Post by Ozwombat » 28 Dec 2018, 08:55

Tried to return to LiF YO today after taking some time off and the game will no longer load. It says "running" in my games library menu, but nothing happens, not even a loading screen appears.Then have to Ctrl Alt Delete to shut down steam, to stop it "running" LiF doesn't even show up in the Task Manager as a running program. I ran the "verify files" option, that said I was missing 10 required files. OK. Uninstalled LiF YO, re-installed. Did not fix. Still won't run what so ever. Tried LiF MMO it worked fine, went straight to a updating/play game screen. But that was going to take 4-5 hours to update, but at least it look like it would of worked. I can't think of anything else to try, to get the game working again. Any (sensible) advice would be much appreciated. TIA

User avatar
Posts: 5463
Joined: 25 Oct 2013, 14:11
Location: Sparksvaard, the middle world; the world of people.

Re: LiF YO Not Working!!

Post by Arrakis » 29 Dec 2018, 12:28

Did you attempt clean reinstall? By clean reinstall I mean manually deleting remains of the game to make sure no corrupted files remain.

Return to General Discussion